nixos/hardware/intel-nuc.nix
2023-09-10 21:33:56 +02:00

25 lines
604 B
Nix

{modulesPath, ...}: {
imports = [(modulesPath + "/installer/scan/not-detected.nix")];
# === Boot options ===
boot.initrd.availableKernelModules = ["xhci_pci" "ehci_pci" "ahci" "usbhid" "uas" "usb_storage" "sd_mod"];
boot.initrd.kernelModules = [];
boot.kernelModules = ["kvm-intel"];
boot.extraModulePackages = [];
# === Internal drive ===
fileSystems."/" = {
device = "/dev/disk/by-label/root";
fsType = "ext4";
};
fileSystems."/boot" = {
device = "/dev/disk/by-label/esp";
fsType = "vfat";
};
swapDevices = [
{device = "/dev/disk/by-label/swap";}
];
}